Help & Support
Follow

Discontinuing support for Internet Explorer 8 (IE8)

Due to a lack of support for new capabilities that we are adding to LeanKit and its declining share of our user base, we will no longer support IE8 as of our next release. We will only test new features and enhancements for compatibility with IE9 and above.

To ensure fast and reliable LeanKit service going forward, we recommend using any of the following browsers:

  • IE9 +
  • Chrome
  • Safari
  • Firefox
Have more questions? Submit a request